USDC price calculations intermittently inaccurate

Minor incident Website API Upstream Data Sources
2023-03-11 03:52 UTC · 2 hours, 49 minutes

Updates

Resolved

Messari’s volume-weighted average price for USDC is now reporting in alignment with observed markets. Our engineering team will continue to monitor closely.

March 11, 2023 · 06:41 UTC
Investigating

We have noticed intermittently incorrect USDC prices being broadcast from our market data system. Our engineering team is investigating the issue.

March 11, 2023 · 03:55 UTC

← Back